Other Software

ID #184

Can I use a blog or other content management system?

Applies to: Grid System

Yes, all PHP, perl, python or other cgi weblog scripts and content management systems like WordPress, Geeklog, Pmachine, Greysoft, Blogger, Blosxom, MovableType, Cafelog/B2, Typo3 and many others will work fine.

All you have to do is download the weblog software and install it like any other cgi script.

Remember that regardless of what any instructions that come with these scripts say, a directory containing an executable script, and the script itself should NOT be world writeable.


Last update: 2010-10-03 13:15
Author: FAQ Admin
Revision: 1.2

Digg it! Share on Facebook Print this record Send FAQ to a friend Show this as PDF file
Please rate this FAQ:

Average rating: 0 (0 Votes)

completely useless 1 2 3 4 5 most valuable

You can comment this FAQ

Comment of Anonymous:
I was able to download and install the WordPress blog package in about 60 seconds; it was awesome. I needed to type a couple commands in my SSH shell, but that was it. After making a database in OnSite, here's everything I did:

me:/$ cd /htdocs
me:/htdocs$ wget http://wordpress.org/latest.tar.gz
me:/htdocs$ tar -zxf latest.tar.gz

That's it.

Then I just went to http://wordpress.mydomain.com in my web browser and followed the onscreen instructions. (2 simple steps.)
Added at: 2005-04-27 16:44

Comment of Anonymous:
An important thing to note, when setting up WordPress, is that (as of 1.5.1, apparently) you need to be sure that your DB_HOST is set to "db.modwest.com" in wp-config.php, or else you'll get a very confusing and unhelpful error. Presumably this bad error message will be patched in the next version, but it gave me trouble today.
Added at: 2005-05-14 16:57

Comment of Anonymous:
To use Wordpress version 2 you need to enable the following xml extensions in your php.ini:

extension = domxml.so ;domxml - document object model
extension = xml.so ; xml - XML parser functions

Here is another FAQ that can help to enable these modules:
http://www.modwest.com/help/kb5-99.html

Wordpress v.2 will not work without those extensions.

Added at: 2006-11-08 12:30

Comment of Anonymous:
It took me a moment to realize that my DB Server is actually "db1.modwest.com". Just a heads up.
Added at: 2008-05-04 22:51